Thunderbird サポート
ナレッジベース - メッセージの件名が文字化けしたり「?」になってしまう
- OS: すべてのシステム
- バージョン: 3.1 / 5.0 以降
- カテゴリ: 製品の機能・操作に関する問題
特定の送信者から届いたメッセージの件名が正しく表示されません。文字化けしたり「?」に置き換えられ、読むことができません。本文は文字化けしていません。
原因
送信者側の問題です。日本語のメールには、主に ISO-2022-JP という文字コードが使われますが、件名・宛先等のヘッダ部分に Shift_JIS など別の文字コードが混ざりますと、文字化けする可能性が高くなります。
一般的なメールソフトであれば、日本語のメールに最適な設定が行われており、通常は問題ありません。特にニュースレターなど CGI プログラムを通じて配信されているメールで、指定された文字コードと実際の文字コードが異なる場合に、この問題が起きる可能性があります。
この問題は Thunderbird に限らず、他のメールソフトでも見られます。ただし、Outlook および Outlook Express では、文字コードが強制的に変換され、文字化けしない場合があります。
解決策
送信者に連絡を取って、件名が文字化けする旨を伝え、修正を依頼してください。